Woodnet Forums
Burned out motor Delta 14-651 Mortiser - Printable Version

+- Woodnet Forums (https://forums.woodnet.net)
+-- Thread: Burned out motor Delta 14-651 Mortiser (/showthread.php?tid=7347711)



Burned out motor Delta 14-651 Mortiser - bpatters69 - 04-15-2019

Hello All,

I was cleaning up my Delta 14-651 Mortiser over the weekend as I have not used it in a while. I figured I would turn it on and let it run for a while and when I turned it on, it was making an odd noise. I cannot really describe it. After a few minutes, the noise went away so I did no think any more about it. After about 5 or 10 minutes of running, I noticed a slight odor and then I heard the motor start to slow down. The motor did not stop completely but I noticed when I tried to apply resistance to the chuck that the chuck was slipping and the engine was not apply much torque.

I am fairly sure the engine is friend. I looked online to see what a 1/2 HP motor would cost and the pricing is ridiculous. I saw pricing from $300 and up. A new mortise is only like $400. Has anyone replaced a motor in the 14-651 with a non-Delta brand of motor that is reasonably priced? Anyone have ideas for options on what to do? I have already considered binning it...

I like Delta but I have to say, I have not used the mortise a whole lot but I have had it for a few years now. I would be surprised if I used it for more than 3 or 4 hours. I doubt I will buy another Mortiser as I hardly used this one.

Thanks, Bill


RE: Burned out motor Delta 14-651 Mortiser - John Mihich - 04-15-2019

For me I would try new brushes if they have them and while you have it apart check the bearings.  Both are cheap and easy to get to.


RE: Burned out motor Delta 14-651 Mortiser - bpatters69 - 04-15-2019

(04-15-2019, 02:38 PM)John Mihich Wrote: For me I would try new brushes if they have them and while you have it apart check the bearings.  Both are cheap and easy to get to.

Thanks John. It sounds like its worth a shot. I downloaded the manual but it is not specific about the motor. The cap comes off fairly easily. There are 3 screws but there is probably more to it when it comes to getting tot he innards of the motor. Like I said there was a bit of an odor. The unit also became very hot around the motor housing.


RE: Burned out motor Delta 14-651 Mortiser - TDKPE - 04-15-2019

Check the centrifugal switch under the fan.  If it’s stuck, which happens too much, the start winding will remain engaged and start overheating.  The capacitor may also be damaged.

Some of those Delta motors, while looking like TEFC frames, are actually open under the fan and can accumulate dust inside.  Dried lube and/or dust buildup can stop that switch from opening at speed.  And it will run weird while the main windings are fighting with the start windings, draw a lot of current, and run real hot.  If it gets hot enough, it’ll start getting weak.

If you’re going to crack it open anyway, you’ll get to those parts before you remove the end bell, so easy enough to check.


RE: Burned out motor Delta 14-651 Mortiser - ajkoontz - 04-16-2019

Sorry about your luck. You might be able to get some of your money back parting it out. Parts for these are getting very hard to find. I busted a few of the plastic/ pot metal hold down knobs and spent around $50 for replacement parts a month or so ago. If you decide not to fix it i'll bet you could sell most of the parts on ebay.


RE: Burned out motor Delta 14-651 Mortiser - TGW - 04-16-2019

Would it be possible to rewind?

I am currently struggling to learn to rewind motors as an amateur and it is complicated though not impossible.


RE: Burned out motor Delta 14-651 Mortiser - bpatters69 - 04-18-2019

(04-15-2019, 06:18 PM)TDKPE Wrote: Check the centrifugal switch under the fan.  If it’s stuck, which happens too much, the start winding will remain engaged and start overheating.  The capacitor may also be damaged.

Some of those Delta motors, while looking like TEFC frames, are actually open under the fan and can accumulate dust inside.  Dried lube and/or dust buildup can stop that switch from opening at speed.  And it will run weird while the main windings are fighting with the start windings, draw a lot of current, and run real hot.  If it gets hot enough, it’ll start getting weak.

If you’re going to crack it open anyway, you’ll get to those parts before you remove the end bell, so easy enough to check.

Thanks for all the suggestions.

I am going to take off the cover and then the fan. I will take some pictures and post them. I hate to admit it but I do not know much about engines. Maybe the pictures can help someone identify what is wrong. I will post them in a day or two. I also contacted a local, small engine guy. He is willing to look at it so I might just take it to him.

I know the replacement cost of the motor is ridiculous compared to the price of a new mortiser. I barely used this one so it is unlikely I will get another one.