Woodnet Forums
Porter-Cable FN250C not firing - Printable Version

+- Woodnet Forums (https://forums.woodnet.net)
+-- Thread: Porter-Cable FN250C not firing (/showthread.php?tid=7357571)



Porter-Cable FN250C not firing - bmich - 09-03-2020

I have a Porter-Cable FN250C although that might not be the correct model number.  Its the exact same gun, just about 10 years old.  Recently it stopped firing nails.  I would pull the trigger and press down and nothing will happen.  Does anyone have any suggestions on what to do to fix this. I was trying to shoot 2 1/2 16AWG finish nails, if that matters.


RE: Porter-Cable FN250C not firing - Stwood_ - 09-03-2020

Dry or broken internal o-ring, driver bump pad inside is crushed, or dry/broken driver.

Release the front jam removal cover and push the driver up into the gun *if* it is hanging down. Lube it with some oil. It may just be dry and bound up.


RE: Porter-Cable FN250C not firing - Flat Lander - 09-03-2020

If you have air coming from exhaust on top, your bumper stop has disintegrated, remove the top cap and be careful to note the orientation of the parts for reassembly.

I got my parts from here https://www.ereplacementparts.com/porter-cable-fn250c-type-21234-finish-nailer-kit-parts-c-129_1717_16563.html


RE: Porter-Cable FN250C not firing - bmich - 09-03-2020


Thanks everyone, Ill look at it this weekend.


RE: Porter-Cable FN250C not firing - tomsteve - 09-04-2020

(09-03-2020, 11:58 PM)bmich Wrote:
Thanks everyone, Ill look at it this weekend.
make sure ya dont have a nail jammed first. mine will lock up occasionally ifnit needs oil


RE: Porter-Cable FN250C not firing - bmich - 09-06-2020

(09-04-2020, 06:24 AM)tomsteve Wrote: make sure ya dont have a nail jammed first. mine will lock up occasionally ifnit needs oil

Maybe I should add that I was using it for a while while it was working, then it started to misfire and then completely stopped. I was installing some baseboards and wham, just stopped.


RE: Porter-Cable FN250C not firing - bmich - 09-06-2020

Update, I took apart everything and I could not see any missing O rings. Nothing looks bad, however, when I press down and pull the trigger I get air leaking from the trigger area. Does that mean the trigger assembly is bad? I took that apart and didnt see anything that obviously looked bad.


RE: Porter-Cable FN250C not firing - Stwood_ - 09-06-2020

O-rings seldom disappear. Worn o-rings leak. And you may not be able to tell if it is worn.
Scroll to the bottom part.... questions.

https://www.ereplacementparts.com/porter-cable-fn250c-type-21234-finish-nailer-kit-parts-c-129_1717_16563.html


RE: Porter-Cable FN250C not firing - bmich - 09-07-2020

Thanks all, I purchased the o ring kit, the replacement parts store says my order will leave the warehouse in 12-18 days. Ill update then.


RE: Porter-Cable FN250C not firing - Cabinet Monkey - 10-17-2020

(09-07-2020, 12:45 PM)bmich Wrote: Thanks all, I purchased the o ring kit, the replacement parts store says my order will leave the warehouse in 12-18 days.  Ill update then.

Replacements say they have 25 on hand.   

Might want to reevaluate part source.